
1. Vytvorenie nového projektu v programe Vivado HLS použitím  Zynq 

xc7z020clg484-1 (ZedBoard) alebo  xc7z010clg400-1 (Zybo) 

1.1. Spusťte Vivado HLS cez Start > Všetky programy > Xilinx Design Tools > Vivado HLS 

2015.4. 

Zobrazí sa úvodná strana programu. 

 

Obrázok 1 Úvodný obraz po spustení Vivado HLS 

 

1.2. Na úvodnej strane kliknite na Create New Project alebo choďte cez File > New Project... Otvorí 

sa dialógové okno New Vivado HLS Project. 

 

1.3. V riadku Project name nazvite projekt matrixmul.prj.  

 

1.4. Kliknite na  Browse... pre voľbu umiestnenia projektu a uložte ho do C:\Vivado_projects\lab1. 

Potom kliknite na OK. 

 

Obrázok 2 Nový projekt vo Vivado HLS 

 



1.5. Kliknite na Next. 

 

1.6. V okne Add/Remove Files v riadku Top Function napíšte matrixmul ako názov (ten sa musí 

zhodovať so zdrojovými súbormi projektu). 

 

1.7. Kliknite na Add Files... vyberte matrixmul.cpp súbor z C:\Vivado_projects\lab1 a potom 

kliknite na Open. 

 

1.8. Kliknite na Next. 

 

1.9. V okne Add/Remove Files pre test kliknite na Add Files..., vyberte matrixmul_test.cpp súbor 

z C:\Vivado_projects\lab1 a následne kliknite na Open. 

 

1.10. Kliknite na súbor matrixmul_test.cpp v zozname súborov a následne kliknite na Edit CFLAGS... 

a ako CFLAGS položku uveďte -DHW_COSIM, kliknite na OK. 

 

1.11. Kliknite na Next. 

 

1.12. V okne Solution Configuration nechajte Solution Name solution1 a zmeňte taktovací cyklus na 

10 (pre ZedBoard) alebo 8 (pre Zybo). Riadok Uncertainty nechajte prázdny (ZedBoard si stanoví 

predvolenú hodnotu na 1.25 a Zybo na 1). 

Kliknite na ... v časti Part Selection. 

 

1.13. Zobrazí sa nové okno Device Selection Dialog, v ktorom vyberte súčasť xc7z020clg484-1 

(ZedBoard) alebo  xc7z010clg400-1 (Zybo). 

Vo filtri vyberte: 

 Family: zynq 

 Sub_Family: zynq 

 Package: clg484 (ZedBoard) alebo clg400 (Zybo) 

 Speed grade: -1 



 

Obrázok 3 Výber súčastí pre ZedBoard 

 

 

Obrázok 4 Výber súčastí pre Zybo 

Pre ZedBoard je možné v časti Boards vybrať príslušnú dosku, pokiaľ nejaké na výber máme. 

 

Obrázok 5 Výber Boards pre ZedBoard 

 



1.14. Kliknite na OK 

 

1.15. Kliknite na Finish 

Následne sa vytvorí projekt, ktorý môžete vidieť v okne Explorer. 

 

Obrázok 6 Okno Explorer 

Rozbalením jednotlivých priečinkov môžete vidieť položky patriace k danému 

priečinku/podpriečinku. 

 

1.16. Dvojitým klikom na matrixmul.cpp sa otvorí zdrojový kód projektu matrixmul.prj.  

 

Obrázok 7 Zdrojový kód projektu matrixmul.prj 

Ako môžete vidieť, program je zameraný na násobenie matice. Skladá sa z troch cyklov.  Cyklus 

Product je najvnútornejší cyklus, ktorý vykonáva násobenie a následné sčítavanie jednotlivých 

prvkov matice. Výsledok sa uloží na dané súradnice výslednej matice, podľa toho, ako máme 

určené [i] a [j]. Stredný cyklus Col vykonáva posúvanie sa po stĺpcoch matice. Taktiež sa tu 

vykonáva vynulovanie res[i][j], keď cyklus Product prešiel všetkými riadkami daného stĺpca 

a prechádza sa na nový stĺpec. Cyklus Row je najvrchnejší cyklus a vykonáva posúvanie sa po 

riadkoch matice. 

 

 

 



2. Spustenie C simulácie (Run C Simulation) 

2.1.  C simuláciu je možné spustiť cez Project > Run C Simulation, alebo kliknutím  

na   na paneli nástrojov. Zobrazí sa nové dialógové okno C Simulation, v ktorom kliknite na 

OK. 

 

2.2. Po skončení simulačného behu môžete v spodnej časti programu v okne Console vidieť výstup 

simulácie. 

 

Obrázok 8 Výstup simulácie 

 

2.3. Rozbaľte priečinok Test Bench v okne Explorer a dvakrát kliknite na matrixmul_test.cpp. 

V úvode zdrojového kódu môžete vidieť dve inicializované matice so vstupnými údajmi a ďalej 

algoritmy, ktoré sa v rámci kódu vykonávajú. Ak je definované HW_COSIM, funkcia matrixmul 

je volaná a výsledok, ktorý je vypočítaný sa porovnáva s hodnotou vrátenou z volajúcej funkcie. 

Ak sa výsledky zhodujú, na konci simulácie sa okrem výsledku vypíše aj Test passed (Testom 

potvrdené). Ak HW_COSIM definované nie je, funkcia matrixmul nie je volaná. 

 

 

3. Spustenie debugger-a  

3.1. Vyberte Project > Run C Simulation alebo kliknite na  na paneli nástrojov. Na zobrazenom 

dialógovom okne, je potrebné označiť Launch Debugger a následne kliknúť na OK. 

Aplikácia sa skompiluje a automaticky sa otvorí pohľad debuggera. 

 

3.2. V debugger-i môžete matrixmul_test.cpp vidieť zo zdrojového pohľadu. Premenné argc a argv sú 

definované v okne Variables, okno Outline zobrazuje objekty v aktuálnom rozsahu. 



 

Obrázok 9 Okno debugger-a 

 

3.3. Presuňte sa v zdrojovom kóde matrixmul_test.cpp na riadok 105 a dvakrát kliknite na modro 

sfarbený stĺpec pri tomto riadku.  

Po tomto kliku sa na danom mieste objaví bod prerušenia (modrý krúžok s fajkou). 

 

 

3.4. Rovnako kliknite aj na riadok 101, kde je definovaná funkcia matrixmul(). 

 

3.5. Niekoľkokrát kliknite na Step Over (F6) ( ) a sledujte ako sa menia hodnoty jednotlivých 

premenných v okne Variables. Zároveň budete vidieť, na ktorom riadku zdrojového kódu sa 

momentálne nachádzate. 



 

Obrázok 10 Krokovanie zdrojového kódu 

 

3.6. Kliknite na Resume ( ) alebo stlačte F8 pre dokončenie výpočtu a program sa zastaví na 

riadku 101, ktorý sme si v predchádzajúcom kroku označili. 

 

3.7. Pozorujte vypočítaný výsledok v okne Variables. 

 

Obrázok 11 Softvérový výsledok programu 



3.8. Kliknite na Step Into (F5)  ( )  na prejdenie do matrixmul modulu a sledujte, či sa program 

zastavil na riadku 75. 

 

3.9. Niekoľkokrát kliknite na Step Over (F6) a sledujte ako sa menia hodnoty premenných v okne 

Variables. Potom kliknite na Step Return (F7)  pre návrat z funkcie.  

 

3.10. Program bude pokračovať na riadku 105, ktorý sme si označili v predchádzajúcom kroku bodom 

prerušenia. Softvérové a hardvérové výsledky môžete sledovať v okne Variables. 

 

Obrázok 12 Softvérový a hardvérový výsledok programu 

 

3.11. Vložte bod prerušenia na riadok 134 (return err_cnt) a kliknite na Resume. Program bude 

pokračovať až po riadok 134. V okne Console sa zobrazí výsledok, ktorý ste mohli vidieť 

v predchádzajúcom kroku (krok 2.2, Obrázok 8). 

 

3.12. Cez tlačítko Resume alebo Terminate je debagger možné kedykoľvek vypnúť. 

 

 

4. Spustenie syntézy (Run C Synthesis) 

4.1. Prepnite pohľad z Debug na Synthesis kliknutím na  na paneli nástrojov. 

 



4.2. Vyberte Solution > Run C Synthesis > Active Solution alebo kliknite na . 

 

4.3. Po spustení syntézy sa zobrazí  súhrnná správa (Synthesis Report) spolu s Outline oknom. Okno 

Outline vás bude navigovať zobrazeným výsledkom jednoduchým kliknutím na jednotlivé časti. 

 

4.4. Ak rozbalíte priečinok solution1, môžete vidieť, že boli automaticky vygenerované a vložené 

súbory do podpriečinka syn > report. 

 

Obrázok 13 Okno Explorer po vykonaní syntézy 

Všimnite si, že ak rozbalíte podpriečinok syn v priečinku solution1 v okne Explorer, nachádzajú 

sa tam ďalšie podpriečinky report, systemc, verilog a vhdl v rámci ktorých sú generované (vhdl, 

verilog, hlavičkový a cpp) súbory. Dvojitým klikom na tieto súbory sa vám zobrazí ich obsah 

v informačnom okne.  

 

4.5. Súhrnná správa zobrazuje odhad výkonu a využitia ako aj odhad latencie v navrhnutom programe. 

 

4.6. Prechádzajte informačným oknom a odpovedzte na nasledujúce otázky 

Odhadovaná perióda taktu:   ____________________ 

Najhorší prípad latencie:   ____________________ 

Celková hodnota DSP48E:  ____________________ 

Celková hodnota FF:   ____________________ 

Celková hodnota LUT:   ____________________ 

 



4.7. Správa tiež zobrazuje najvyššie úrovne signálov rozhrania vytvorené nástrojmi. 

 

Obrázok 14 Generované signály rozhrania 

Môžete si všimnúť, že riadiace signály ap_clk, ap_rst, ap_idle a ap_ready boli automaticky dané 

do dizajnu. Tieto signály sú používané ako tzv. handshaking signály, ktoré ukazujú, kedy je dizajn 

pripravený začať vykonávať ďalší príkaz výpočtu (ap_ready), kedy ďalší výpočet začal (ap_start) 

a kedy sú výpočty dokončené (ap_done). Ostatné signály sa generujú na základe vstupných 

a výstupných signálov v dizajne a ich predvolených alebo zadaných rozhraní. 

 

 

5. Používanie Pohľadu analýzy (Analysis Perspective) 

5.1. Vyber Solution > Open Analysis Perspective alebo klikni na panely nástrojov na

 pre otvorenie pohľadu analýzy. 

V nasledujúcom pohľade môžete vidieť niekoľko okien.  

Okno Module Hierarchy zobrazuje výkon a informácie celého dizajnu a je možné ho použiť na 

navigáciu hierarchiou.  

Okno Performance Profile zobrazuje podrobnosti o výkone pre danú úroveň hierarchie. 

Informácie v týchto dvoch oknách sú podobné informáciám, ktoré boli zobrazované v súhrnnej 

správe.  

Okno Performance zobrazuje ako sú operácie v tomto bloku naplánované do hodinových cyklov. 

 ľavý stĺpec zobrazuje prostriedky 

 horný riadok zobrazuje stavy c0 až c5. Sú to vnútorné stavy používané na vysokej 

úrovni syntézy na naplánovanie operácií v hodinových cykloch 



 

Obrázok 15 Pohľad analýzy 

 

5.2. Rozbaľte jednotlivé cykly Row, Col a Product kliknutím na + pri ich názve. 

 

Obrázok 16 Zobrazenie jednotlivých cyklov rozbalením cyklu Row 

Z toho môžete vidieť, že v prvom stave C1 cyklu Row sa kontroluje ukončovacia podmienka (exit 

condition) a vykonávajú sa tu pridávacie operácie. Okrem toho je to počítadlo na sčítavanie počtu 

iterácií cyklu.  

Operácie vyplývajúce z cyklu sú zafarbené na žlto, štandardné operácie sú zafarbené na fialovo 

a ostatné čiastkové bloky sú zafarbené na zeleno (v našom prípade nemáme žiadne funkcie na 

nižšej úrovni). 

 

5.3. Kliknite pravým tlačidlom myši na fialové políčko stavu C1 riadku 4 a vyberte možnosť Goto 

Source. 



Panel so zdrojovým kódom sa zobrazí v spodnej časti okna so zvýrazneným 75. riadkom, kde sa 

začína cyklus Row svoju činnosť.  V ďalšom stave (C2) začína svoju činnosť cyklus Col. 

 

Obrázok 17 Zobrazenie zdrojového kódu cyklu Row 

 

5.4. Rozbaľte všetky položky v okne Performance Profile a všimnite si hodnoty, ktoré obsahujú 

stĺpce Latency,  Iteration Latencies a Trip count jednotlivých cyklov. 

 

Obrázok 18 Okno Performance Profile 

Počet iterácií je možné vidieť aj podržaním myši na žlté riadky jednotlivých cyklov v okne 

Performance (zobrazené dialógové okno zobrazuje štatistiku cyklu). 

 

Obrázok 19 Štatistika cyklu 

 

5.5. Kliknite na matrixmul v okne Modul Hierarchy a všimnite si, že položka nie je rozšírená, pretože 

v dizajne nie sú definované žiadne funkcie na nižšej úrovni. 



5.6. Prepnite sa na okno Resource Profile a pozorujte jednotlivé zdroje, kde boli použité. Rozbalením 

sekcií Expressions a Registers môžete vidieť ako boli zdroje využité, v ktorých operáciách. 

 

Obrázok 20 Okno Resource Profile 

 

5.7. V okne Resource(solution1) sa prepnite na kartu Resource  a rozbaľte položky I/O Ports a 

Memory Ports. Pozorujte, ktoré operácie a prostriedky boli použité, a v ktorom stave sa používali. 

 

Obrázok 21 Karta Resource 

 

5.8. Kliknite na Synthesis na paneli nástrojov pre návrat na pohľad Synthesis. 

 

 

 

 



6. Spustenie C/RTL Co-simulácie 

6.1. Vyberte Solution > Run C/RTL Cosimulation alebo kliknite na  na paneli nástrojov, ak sa 

nachádzate v pohľade Synthesis. Následne sa zobrazí dialógové okno. 

6.2. V časti RTL Selection vyberte možnosť VHDL. 

 

Obrázok 22 C/RTL Co-simulation dialógové okno 

 

6.3. Kliknite na OK pre spustenie VHDL simulácie. 

C/RTL Co-simulácia sa spustí, vygeneruje sa a skompiluje niekoľko súborov a následne sa 

nasimuluje dizajn. Prechádza tromi fázami. 

 Najprv sa VHDL test vykonáva pre generovanie vstupných podnetov pre RTL dizajn 

 Potom je vytvorený RTL test s novo vygenerovanými vstupnými podnetmi a následne 

prebieha RTL simulácia 

 Nakoniec sa výstup z RTL porovná s výsledok z VHDL testu. 

V konzolovom okne môžete vidieť postup a správu o schválenom výsledku (Test passed). 



 

Obrázok 23 Konzolové okno po ukončení co-simulácie 

 

6.4. Akonáhle je simulácia dokončená, otvorí sa správa o co-simulácii v konzolovom okne. Správa 

hovorí, či bol výsledok simulácie schválený alebo nie. Okrem toho správa zobrazuje namerané 

latencie a interval. 

Vzhľadom k tomu, že sme vybrali len VHDL, výsledok zobrazuje latencie a interval, ktoré 

označujú po koľkých hodinových cykloch bude možné poskytnúť ďalší vstup. 

 

 

7. Zobrazenie výsledkov simulácie vo Vivado 

7.1. Spustenie Verilog simulácie so zvolenými nastaveniami Dump Trace 

7.1.1. Vyberte Solution > Run C/RTL Cosimulation alebo kliknite na  na paneli nástrojov. 



7.1.2. V zobrazenom dialógovom okne kliknite v časti RTL Selection vyberte možnosť Verilog 

a ponechajte možnosť Auto v časti Verilog/VHDL Simulator. 

 

7.1.3. Vyberte možnosť All v časti Dump Trace a kliknite na OK. 

 

Obrázok 24 Nastavenie pre Veriloc co-simuláciu 

 

Akonáhle je co-simulácia dokončená, automaticky sa zobrazí v konzolovom okne 

potvrdzovacia správa o schválenom výsledku. Navyše preto, že boli použité nastavenia Dump 

Trace a Verilog, v adresári simulácie Verilog môžete vidieť dve súborové položky. 

 

Obrázok 25 Okno Explorer po skončení Verilog co-simulácie 

Správa co-simulácie ukazuje, že test pre Verilog bol schválený spolu s výsledkami pre latencie 

a interval. Taktiež môžete vidieť výsledky z predchádzajúceho spustenia co-simulácie. 



7.2. Spustenie Vivado 2015.4 a vloženie príkazov do príkazového riadku  

7.2.1. Spustite Vivado 2015.4 cez Štart > Všetky programy > Xilinx Design Tools > Vivado 2015.4 

 

7.2.2. Po spustení programu napíšte nasledujúce príkazy do príkazového riadku okna Tcl Console 

cd c:/Vivado_projects/lab1/matrixmul.prj/solution1/sim/Verilog 

current_fileset 

open_wave_database matrixmul.wdb 

create_wave_config 

add_wave / 

 

Po zadaní predchádzajúcich príkazov sa načíta projekt, výsledky a priebeh simulácie. 

 

7.2.3. V okne kde sa nachádza priebeh simulácie kliknite na  pre plné priblíženie aby ste v rámci 

simulácie videli jednu iteráciu. 

 

7.2.4. V okne Objects vyhľadajte a_address0. Na nájdený výsledok kliknite pravým tlačidlom myši 

a vyberte možnosť Radix > Unsigned Decimal. To isté spravte aj pre  b_address0 a 

res_address0. 

 

7.2.5. Tak isto vyhľadajte  a_q0, b_q0, a res_d0 a vybrte možnosť Radix > Signed Decimal. 

 

7.2.6. V priebehu simulácie sa mierne posuňte nižšie aby ste videli signály rozhrania ap_*. 

 

Obrázok 26 Priebeh simulácie 



Všimnite si, že akonáhle sa začal vykonávať ap_start, ap_idle skončil svoju činnosť čo značí, 

že dizajn je v režime počítania. Signál ap_idle je vypnutý pokiaľ sa nevykoná signál ap_done, 

ktorý značí dokončenie procesu. To znamená 106 hodinových cyklov latencie. 

 

7.2.7. Použite tlačidlo priblíženia tak, aby ste videli priebeh od  ~120 do  ~550 ns. 

Všimnite si, že dizajn očakáva prvky, ktoré poskytujú signály a_address0, a_ceo, b_address0, 

b_ceo a výsledok na výstupe používa res_d0, res_we0 a res_ce0. 

 

7.2.8. Prezrite si aj ostatné časti simulácie a pokúste sa pochopiť, ako dizajn funguje. 

 

7.2.9. Po prezretí, vyplite Vivado cez File > Exit. Kliknite na OK a vypnite program bez uloženia 

(možnosť Discard). 

 

 

8. Export RTL a implementácia 

8.1. Vo Vivado HLS vyberte Solution > Export RTL alebo kliknite na . 

Otvorí sa dialógové okno Export RTL Dialog. 

 

Obrázok 27 Dialógové okno pre export RTL 

S predvolenými nastaveniami (uvedené vyššie), spustí sa tzv. IP balíčkovací proces a vytvorí 

balík pre Vivado IP katalóg. S ďalšími možnosťami z rozbaľovacieho menu je možné vytvoriť IP 

balíčky pre Systém Generátor DSP/Systém Generátor využívajúci ISE, vytvoriť pcore pre Xilinx 

Platform Studio alebo vytvoriť Syntetizačný kontrolný bod. 

 



8.2. V časti Option rozbaľte menu a vyberte možnosť VHDL a zaškrtnite možnosť Evaluate 

(vyhodnotiť). 

 

8.3. Kliknite na OK spustí sa implementácia. 

Môžete sledovať jednotlivé kroky v konzolovom okne Vivado HLS. Implementácia prechádza 

niekoľkými fázami: 

 Exportovanie RTL ako IP v IP-XACT formáte 

 Vyhodnotenie RTL, pretože ste zvolili možnosť Evaluate 

o  prechádzajúce cez syntézu 

o  prechádzajúce cez Umiestnenie a Smerovanie 

Po skončení exportu sa v informačnom okne zobrazí správa. 

Môžete si všimnúť, že sa načasovania stretli, ďalej si všimnite dosiahnuté periódy (7.522 

[ZedBoard], 5,943 [Zybo]) a typ s množstvom prostriedkov, ktoré boli použité. 

 

8.4. V okne Explorer pozorujte, či bol vytvorený súbor impl v rámci ktorého sa vytvorili podpriečinky 

ip, report, verilog a vhdl. 

 

Obrázok 28 Okno Explorer po dokončení exportu 

 

8.5. Rozbaľte podpriečinok verilog a vhdl a všimnite si, že podpriečinok verilog má len rtl súbor, 

zatiaľ čo podpriečinok vhdl  má súborov niekoľko. 

Okrem iného sa tu nachádzajú aj súbory ako project.xpr (súbor projektu Vivado), 

matrixmul.xdc (súbor na časové obmedzenie), priečinok project.runs (obsahuje podpriečinky 

synth_1 a impl_1, ktoré sa vytvorili pri behu syntézy a implementácie). 



 

Obrázok 29 Adresáre vyplývajúce z implementácie  

 

8.6. Rozbaľte priečinok ip a všimnite si IP balíček ako súbor formátu zip 

(xilinx_com_hls_matrixmul_1_0.zip). Je pripravený na pridanie do Vivado katalógu. 

 

Obrázok 30 Obsah priečinku ip 

 

8.7. Zatvorte Vivado HLS výberom File > Exit. 

 

 

 

 

 



Odpovede 

Odhadovaná perióda taktu:   8.34 ns (ZedBoard) / 6.38 ns (Zybo) 

Najhorší prípad latencie:  106 (ZedBoard)  133 (Zybo) ______ 

Celková hodnota DSP48E:  _____1________________________ 

Celková hodnota FF:   _____61 (ZedBoard)_78 (Zybo)____ 

Celková hodnota LUT:   _____68 (ZedBoard)  69 (Zybo)____ 

 


